DRS HELP DESK

 
 

 
Knowledgebase: Public KB
Is QuickSell 2000 PCI compliant?
Posted by DRS Support Team on 09 June 2015 11:46 AM

No version of QuickSell 2000 (discontinued) is PCI compliant. The last update to the program was in 2001.
For PCI compliance, you will need to upgrade to Microsoft Dynamics...

Please Register AND/OR login (upper right) to view full article contents.

(1 vote(s))
Helpful
Not helpful

Comments-login required (0)